const regex = /ng-click="vm\.onClickTab\((.*?)'\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ng-click="vm\\.onClickTab\\((.*?)\'\\)', 'g')
const str = ` ng-click="vm.onClickTab('wanted')"`;
const subst = `ng-click="vm\.onClickTab\($1', $event\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);