#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "ng-click="vm\.onClickTab\((.*?)'\)"
Local $sString = " ng-click="vm.onClickTab('wanted')""
Local $sSubst = "ng-click="vm\.onClickTab\($1', $event\)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)