$re = '/ng-click="vm\.onClickTab\((.*?)\'\)/';
$str = ' ng-click="vm.onClickTab(\'wanted\')"';
$subst = "ng-click=\"vm\.onClickTab\($1', $event\)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;