// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"ng-click="vm\.onClickTab\((.*?)'\)"#).unwrap();
let string = " ng-click=\"vm.onClickTab('wanted')\"";
let substitution = "ng-click=\"vm\\.onClickTab\\($1', $event\\)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}