# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ng-click="vm\.onClickTab\((.*?)'\)/ng-click="vm\.onClickTab\($1', $event\)/g;t' <<< " ng-click=\"vm.onClickTab('wanted')\""