re = /(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b/m
str = 'Оганян
Яндарбиев
Геворгянц
Маштоц
Гурунц
Адонц
Багратуни
Месроп Маштоц проверят границу слова
Меликоянов
Малоямпольский
Давид Сасунский
Мовсес Хоренаци
Арам Габрелянов
Воротнеци
Харкаци
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end