import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((у|я|о)н(и|ц)?(ов)?)|(ци?))\\b";
final String string = "Оганян\n"
+ "Яндарбиев\n"
+ "Геворгянц\n"
+ "Маштоц\n"
+ "Гурунц\n"
+ "Адонц\n"
+ "Багратуни\n"
+ "Месроп Маштоц проверят границу слова\n"
+ "Меликоянов\n"
+ "Малоямпольский\n"
+ "Давид Сасунский\n"
+ "Мовсес Хоренаци\n"
+ "Арам Габрелянов\n"
+ "Воротнеци\n"
+ "Харкаци\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}