using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b";
string input = @"Оганян
Яндарбиев
Геворгянц
Маштоц
Гурунц
Адонц
Багратуни
Месроп Маштоц проверят границу слова
Меликоянов
Малоямпольский
Давид Сасунский
Мовсес Хоренаци
Арам Габрелянов
Воротнеци
Харкаци
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}