use strict;
my $str = 'Оганян
Яндарбиев
Геворгянц
Маштоц
Гурунц
Адонц
Багратуни
Месроп Маштоц проверят границу слова
Меликоянов
Малоямпольский
Давид Сасунский
Мовсес Хоренаци
Арам Габрелянов
Воротнеци
Харкаци
';
my $regex = qr/(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}