#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b"
Local $sString = "Оганян" & @CRLF & _
"Яндарбиев" & @CRLF & _
"Геворгянц" & @CRLF & _
"Маштоц" & @CRLF & _
"Гурунц" & @CRLF & _
"Адонц" & @CRLF & _
"Багратуни" & @CRLF & _
"Месроп Маштоц проверят границу слова" & @CRLF & _
"Меликоянов" & @CRLF & _
"Малоямпольский" & @CRLF & _
"Давид Сасунский" & @CRLF & _
"Мовсес Хоренаци" & @CRLF & _
"Арам Габрелянов" & @CRLF & _
"Воротнеци" & @CRLF & _
"Харкаци" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")