$re = '/(((у|я|о)н(и|ц)?(ов)?)|(ци?))\b/m';
$str = 'Оганян
Яндарбиев
Геворгянц
Маштоц
Гурунц
Адонц
Багратуни
Месроп Маштоц проверят границу слова
Меликоянов
Малоямпольский
Давид Сасунский
Мовсес Хоренаци
Арам Габрелянов
Воротнеци
Харкаци
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);