const regex = new RegExp('(((у|я|о)н(и|ц)?(ов)?)|(ци?))\\b', 'gm')
const str = `Оганян
Яндарбиев
Геворгянц
Маштоц
Гурунц
Адонц
Багратуни
Месроп Маштоц проверят границу слова
Меликоянов
Малоямпольский
Давид Сасунский
Мовсес Хоренаци
Арам Габрелянов
Воротнеци
Харкаци
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}