import Foundation
let pattern = #"^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Sri Lankan Modern Licence Number Plate Regex #
1-0001
10-0010
111-0000
000-1112
A-3049
KJ-6825
AAC-3422
SP ABC 3429
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)