import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]{1,2})\\s([A-Z]{1,3})\\s([0-9]{4}(?<!0{4}))";
final String string = "# Sri Lankan Modern Licence Number Plate Regex #\n\n"
+ "1-0001\n"
+ "10-0010\n"
+ "111-0000\n"
+ "000-1112\n"
+ "A-3049\n"
+ "KJ-6825\n"
+ "AAC-3422\n\n"
+ "SP ABC 3429";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}