re = /^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))/m
str = '# Sri Lankan Modern Licence Number Plate Regex #
1-0001
10-0010
111-0000
000-1112
A-3049
KJ-6825
AAC-3422
SP ABC 3429'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end