const regex = /^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z]{1,2})\\s([A-Z]{1,3})\\s([0-9]{4}(?<!0{4}))', 'gm')
const str = `# Sri Lankan Modern Licence Number Plate Regex #
1-0001
10-0010
111-0000
000-1112
A-3049
KJ-6825
AAC-3422
SP ABC 3429`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}