# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))"
test_str = ("# Sri Lankan Modern Licence Number Plate Regex #\n\n"
"1-0001\n"
"10-0010\n"
"111-0000\n"
"000-1112\n"
"A-3049\n"
"KJ-6825\n"
"AAC-3422\n\n"
"SP ABC 3429")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.