using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))";
string input = @"# Sri Lankan Modern Licence Number Plate Regex #
1-0001
10-0010
111-0000
000-1112
A-3049
KJ-6825
AAC-3422
SP ABC 3429";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}