#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z]{1,2})\s([A-Z]{1,3})\s([0-9]{4}(?<!0{4}))"
Local $sString = "# Sri Lankan Modern Licence Number Plate Regex #" & @CRLF & _
"" & @CRLF & _
"1-0001" & @CRLF & _
"10-0010" & @CRLF & _
"111-0000" & @CRLF & _
"000-1112" & @CRLF & _
"A-3049" & @CRLF & _
"KJ-6825" & @CRLF & _
"AAC-3422" & @CRLF & _
"" & @CRLF & _
"SP ABC 3429"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")