import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)$";
final String string = "lt_subcontractor_stat\n"
+ "lt_subcontractor_stat_detail\n"
+ "outbound_inbound_stopfactor_report\n"
+ "comparison_stopratio_parcelratio_report\n"
+ "parcels_paid_twice\n"
+ "pickup_cost_per_parcel\n"
+ "delivery_cost_per_parcel\n";
final String subst = "'$1',";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}