import Foundation
let pattern = #"(^|\s*)(!?\/\/)[^\n]+\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
// [created|updated|readed|deleted]
textplain
other-text
// Other comment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)