use strict;
my $str = ' // [created|updated|readed|deleted]
textplain
other-text
// Other comment
';
my $regex = qr/(^|\s*)(!?\/\/)[^\n]+\s*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";