re = /(^|\s*)(!?\/\/)[^\n]+\s*/
str = ' // [created|updated|readed|deleted]
textplain
other-text
// Other comment
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result