$re = '/(^|\s*)(!?\/\/)[^\n]+\s*/';
$str = ' // [created|updated|readed|deleted]
textplain
other-text
// Other comment
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;