# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s*)(!?\\/\\/)[^\n]+\s*//g;t' <<< " // [created|updated|readed|deleted]
textplain
other-text
// Other comment
"