using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s*)(!?\/\/)[^\n]+\s*";
string substitution = @"";
string input = @" // [created|updated|readed|deleted]
textplain
other-text
// Other comment
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}