const regex = /(^|\s*)(!?\/\/)[^\n]+\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s*)(!?\\\/\\\/)[^\\n]+\\s*', 'g')
const str = ` // [created|updated|readed|deleted]
textplain
other-text
// Other comment
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);