import Foundation
let pattern = #"col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"col-md-12 dsfgdsfg col-xs-12 col-12 co"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)