re = /col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])/
str = 'col-md-12 dsfgdsfg col-xs-12 col-12 co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end