const regex = /col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('col\\b-(xs|sm|md|lg)?\\b-?\\b(1[0-2]|[1-9])', 'g')
const str = `col-md-12 dsfgdsfg col-xs-12 col-12 co`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}