// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])").unwrap();
let string = "col-md-12 dsfgdsfg col-xs-12 col-12 co";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}