package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])`)
var str = `col-md-12 dsfgdsfg col-xs-12 col-12 co`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}