using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])";
string input = @"col-md-12 dsfgdsfg col-xs-12 col-12 co";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}