$re = '/col\b-(xs|sm|md|lg)?\b-?\b(1[0-2]|[1-9])/';
$str = 'col-md-12 dsfgdsfg col-xs-12 col-12 co';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);