import Foundation
let pattern = #"^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://mohsensoft.com/aff/
www.mohsensoft.com/aff/
mohsensoft.com/aff/
https://www.mohsensoft.com/aff/
https://mohsen.com/aff/
product/daraee
blog.mohsensoft.com/ttt
blog.dsfsf.com
ds-fsf.com/edrger
fg7j.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)