$re = '/^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)/m';
$str = 'https://mohsensoft.com/aff/
www.mohsensoft.com/aff/
mohsensoft.com/aff/
https://www.mohsensoft.com/aff/
https://mohsen.com/aff/
product/daraee
blog.mohsensoft.com/ttt
blog.dsfsf.com
ds-fsf.com/edrger
fg7j.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);