#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)"
Local $sString = "https://mohsensoft.com/aff/" & @CRLF & _
"www.mohsensoft.com/aff/" & @CRLF & _
"mohsensoft.com/aff/" & @CRLF & _
"https://www.mohsensoft.com/aff/" & @CRLF & _
"https://mohsen.com/aff/" & @CRLF & _
"product/daraee" & @CRLF & _
"blog.mohsensoft.com/ttt" & @CRLF & _
"blog.dsfsf.com" & @CRLF & _
"ds-fsf.com/edrger" & @CRLF & _
"fg7j.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")