import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(www.|http[s]?\\:\\/\\/|[\\w\\-_]+\\.\\w+)";
final String string = "https://mohsensoft.com/aff/\n"
+ "www.mohsensoft.com/aff/\n"
+ "mohsensoft.com/aff/\n"
+ "https://www.mohsensoft.com/aff/\n"
+ "https://mohsen.com/aff/\n"
+ "product/daraee\n"
+ "blog.mohsensoft.com/ttt\n"
+ "blog.dsfsf.com\n"
+ "ds-fsf.com/edrger\n"
+ "fg7j.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}