use strict;
my $str = 'https://mohsensoft.com/aff/
www.mohsensoft.com/aff/
mohsensoft.com/aff/
https://www.mohsensoft.com/aff/
https://mohsen.com/aff/
product/daraee
blog.mohsensoft.com/ttt
blog.dsfsf.com
ds-fsf.com/edrger
fg7j.com';
my $regex = qr/^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}