re = /^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)/m
str = 'https://mohsensoft.com/aff/
www.mohsensoft.com/aff/
mohsensoft.com/aff/
https://www.mohsensoft.com/aff/
https://mohsen.com/aff/
product/daraee
blog.mohsensoft.com/ttt
blog.dsfsf.com
ds-fsf.com/edrger
fg7j.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end