# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(www.|http[s]?\:\/\/|[\w\-_]+\.\w+)"
test_str = ("https://mohsensoft.com/aff/\n"
"www.mohsensoft.com/aff/\n"
"mohsensoft.com/aff/\n"
"https://www.mohsensoft.com/aff/\n"
"https://mohsen.com/aff/\n"
"product/daraee\n"
"blog.mohsensoft.com/ttt\n"
"blog.dsfsf.com\n"
"ds-fsf.com/edrger\n"
"fg7j.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.