import Foundation
let pattern = #"(\/dev(\/*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/
/admin
/admin/users
/admin/users::search
/admin/users::add
/admin/users::delete
/admin/database
/admin/database::export
/admin/database::import
/dev
/dev/cache
/dev/cache/local
/dev/cache/remote
/dev/test
/dev/test/unit
/dev/test/unit::execute
/dev/test/e2e
/dev/test/e2e::execute
/stats/
/stats/reports
/stats/reports::download
/stats/reports::print
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)