package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/dev(\/*))`)
var str = `/
/admin
/admin/users
/admin/users::search
/admin/users::add
/admin/users::delete
/admin/database
/admin/database::export
/admin/database::import
/dev
/dev/cache
/dev/cache/local
/dev/cache/remote
/dev/test
/dev/test/unit
/dev/test/unit::execute
/dev/test/e2e
/dev/test/e2e::execute
/stats/
/stats/reports
/stats/reports::download
/stats/reports::print`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}