import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/dev(\\/*))";
final String string = "/\n"
+ "/admin\n"
+ "/admin/users\n"
+ "/admin/users::search\n"
+ "/admin/users::add\n"
+ "/admin/users::delete\n"
+ "/admin/database\n"
+ "/admin/database::export\n"
+ "/admin/database::import\n"
+ "/dev\n"
+ "/dev/cache\n"
+ "/dev/cache/local\n"
+ "/dev/cache/remote\n"
+ "/dev/test\n"
+ "/dev/test/unit\n"
+ "/dev/test/unit::execute\n"
+ "/dev/test/e2e\n"
+ "/dev/test/e2e::execute\n"
+ "/stats/\n"
+ "/stats/reports\n"
+ "/stats/reports::download\n"
+ "/stats/reports::print";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}