#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/dev(\/*))"
Local $sString = "/" & @CRLF & _
"/admin" & @CRLF & _
"/admin/users" & @CRLF & _
"/admin/users::search" & @CRLF & _
"/admin/users::add" & @CRLF & _
"/admin/users::delete" & @CRLF & _
"/admin/database" & @CRLF & _
"/admin/database::export" & @CRLF & _
"/admin/database::import" & @CRLF & _
"/dev" & @CRLF & _
"/dev/cache" & @CRLF & _
"/dev/cache/local" & @CRLF & _
"/dev/cache/remote" & @CRLF & _
"/dev/test" & @CRLF & _
"/dev/test/unit" & @CRLF & _
"/dev/test/unit::execute" & @CRLF & _
"/dev/test/e2e" & @CRLF & _
"/dev/test/e2e::execute" & @CRLF & _
"/stats/" & @CRLF & _
"/stats/reports" & @CRLF & _
"/stats/reports::download" & @CRLF & _
"/stats/reports::print"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")