using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/dev(\/*))";
string input = @"/
/admin
/admin/users
/admin/users::search
/admin/users::add
/admin/users::delete
/admin/database
/admin/database::export
/admin/database::import
/dev
/dev/cache
/dev/cache/local
/dev/cache/remote
/dev/test
/dev/test/unit
/dev/test/unit::execute
/dev/test/e2e
/dev/test/e2e::execute
/stats/
/stats/reports
/stats/reports::download
/stats/reports::print";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}