# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/dev(\/*))"
test_str = ("/\n"
"/admin\n"
"/admin/users\n"
"/admin/users::search\n"
"/admin/users::add\n"
"/admin/users::delete\n"
"/admin/database\n"
"/admin/database::export\n"
"/admin/database::import\n"
"/dev\n"
"/dev/cache\n"
"/dev/cache/local\n"
"/dev/cache/remote\n"
"/dev/test\n"
"/dev/test/unit\n"
"/dev/test/unit::execute\n"
"/dev/test/e2e\n"
"/dev/test/e2e::execute\n"
"/stats/\n"
"/stats/reports\n"
"/stats/reports::download\n"
"/stats/reports::print")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.