re = /(\/dev(\/*))/
str = '/
/admin
/admin/users
/admin/users::search
/admin/users::add
/admin/users::delete
/admin/database
/admin/database::export
/admin/database::import
/dev
/dev/cache
/dev/cache/local
/dev/cache/remote
/dev/test
/dev/test/unit
/dev/test/unit::execute
/dev/test/e2e
/dev/test/e2e::execute
/stats/
/stats/reports
/stats/reports::download
/stats/reports::print'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end