# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*\/).*"
test_str = ("# Remove file name from path\n"
"# I just want to keep the directory the file is in\n\n"
"../data/detect_5wk.csv\n"
"../data/detect_5wk.nb.html\n\n"
"# This means that I will have to do a substitution in R\n"
"# stringr::str_replace(\"../data/detect_5wk.csv\", \"(.*\\\\/).*\", \"\\\\1\")")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.