using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\/).*";
string substitution = @"\1";
string input = @"# Remove file name from path
# I just want to keep the directory the file is in
../data/detect_5wk.csv
../data/detect_5wk.nb.html
# This means that I will have to do a substitution in R
# stringr::str_replace(""../data/detect_5wk.csv"", ""(.*\\/).*"", ""\\1"")";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}